Vdsm on EL6

As of ovirt-3.6, Vdsm is dropping support of the el6 platform. This is a good opportunity to shed legacy code.

List here things that should be dropped: